[Dune-devel] Building dune-common with gcc-4.8 fails

Christian Engwer christian.engwer at uni-muenster.de
Tue Jul 7 16:08:21 CEST 2015


I submitted a bugreport to debian, suggesting to change the
configuration such that the compiler contains the
"-fstack-protector-strong" parameter.

Let's see what the reaction is.

Christian

On Tue, Jul 07, 2015 at 12:22:22PM +0200, Carsten Gräser wrote:
> Hi Ansgar, hi Christoph,
> 
> Am 07.07.2015 um 12:13 schrieb Christoph Grüninger:
> > Hi Carsten,
> > when Ansgar is right, it is not a Dune problem and we should move on.
> > Add it to the known issues. If we gain more knowledge, we still can try
> > to provide a workaround in 2.4.1.
> > If you insist, we can add a check for -f<whateveritwas> and a GCC < 4.9
> > and end configure with an error message.
> I'm happy that we identified this as debian issue. In view of
> this I don't insist on anything, despite _not_ pushing any
> dirty hacks for this. Because the problem does only occur
> if you explicitly select an older compiler and if you use mpich
> it's perfectly OK, to note this as a known issue with debianish
> distributions.
> 
> In case someone explicitly needs this combination we may
> point her/him to the possible workarounds discussed on the
> list.
> 
> Best,
> Carsten
> 



> _______________________________________________
> Dune-devel mailing list
> Dune-devel at dune-project.org
> http://lists.dune-project.org/mailman/listinfo/dune-devel


-- 
Prof. Dr. Christian Engwer 
Institut für Numerische und Angewandte Mathematik
Fachbereich Mathematik und Informatik der Universität Münster
Einsteinstrasse 62
48149 Münster

E-Mail	christian.engwer at uni-muenster.de
Telefon	+49 251 83-35067
FAX		+49 251 83-32729



More information about the Dune-devel mailing list