<html>
<head>
<meta content="text/html; charset=utf-8" http-equiv="Content-Type">
</head>
<body bgcolor="#FFFFFF" text="#000000">
Hi Dominic,<br>
<br>
Yes. Maybe the doc can further state that the command will be
wrapped by mpi<br>
if MPI_RANKS is specified. Although using them together might not be
too useful.<br>
<br>
Conerning CMD_ARGS, both commands have reason to exist, COMMAND
actually changes<br>
the executed command and CMD_ARGS adds argument to an existing
command. <br>
So if COMMAND were a "SINGLE" argument in CMake they would actually
not even overlap.<br>
You can always (I cannot think of a not always case, for &&
which you shouldn't do anyway one would<br>
have to write COMMAND "cmd1 && cmd2" anyway) split a command
in a command and it's arguments.<br>
...<br>
COMMAND ${PYTHON_EXEC},<br>
CMD_ARGS path/testscript.py --type bla --other blub --superfast,<br>
...<br>
<br>
However, I don't see why we need to necessarily put that restriction<br>
on the COMMAND argument. So people can also write<br>
...<br>
COMMAND ${PYTHON_EXEC} path/testscript.py --type bla --other blub
--superfast,<br>
...<br>
if they find it more readable or the split annoying.<br>
<br>
Best wishes<br>
Timo<br>
<br>
<div class="moz-cite-prefix">On 27.10.2015 18:09, Dominic Kempf
wrote:<br>
</div>
<blockquote
cite="mid:CA+Cg7M63DCATuc6mTTK_YgeRUkOdunYcUB0KL_CqwBNGXFkPKg@mail.gmail.com"
type="cite">
<div dir="ltr">
<div>
<div>Greetings, fellow tester,<br>
<br>
</div>
I guess this has some valid use cases. Would you agree with
the following proposal?<br>
<br>
</div>
<div>dune_add_test(...<br>
</div>
<div> [COMMAND cmd1 [cmd2 ..]]<br>
...<br>
)<br>
<br>
</div>
<div>Doc:<br>
</div>
<div>You may specify the COMMAND option to give the exact
command line to be executed<br>
</div>
<div>when running the test. This defaults to the name of the
executable added by dune_add_test<br>
</div>
<div>for this test. Note, that if you specify both CMD_ARGS and
COMMAND, the given CMD_ARGS<br>
</div>
<div>will be put behind your COMMAND.<br>
<br>
<br>
</div>
<div>On the other hand, one might argue, that there should but
one of the CMD_ARGS and COMMAND<br>
</div>
<div>parameters, but somehow repeating the program name just
beacuse you pass an ini file seems silly<br>
</div>
<div>too. Opinions?<br>
<br>
</div>
<div>Best,<br>
</div>
<div>Dominic<br>
</div>
</div>
<div class="gmail_extra"><br>
<div class="gmail_quote">On Tue, Oct 27, 2015 at 6:44 PM, Timo
Koch <span dir="ltr"><<a moz-do-not-send="true"
href="mailto:timo.koch@iws.uni-stuttgart.de"
target="_blank">timo.koch@iws.uni-stuttgart.de</a>></span>
wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0
.8ex;border-left:1px #ccc solid;padding-left:1ex">Hi
Dominic,<br>
<br>
looking over the new command and the application in DuMux I
realized<br>
there is no option yet to alter the test command.<br>
We usually have wrapper scripts execute our executables for
some more fancy tests.<br>
<br>
In add_dune_test the COMMAND variable is hard coded to the
executable name<br>
plus mpi options. Would you be open to incoorporate a
variable COMMAND<br>
on add_dune_test level that would overwrite that default?
This would add quite<br>
a bit of flexiblilty IMO.<br>
<br>
Best wishes<br>
<br>
Timo<br>
<br>
-- <br>
____________________________________________________________________<br>
<br>
Timo Koch phone: <a
moz-do-not-send="true"
href="tel:%2B49%20711%20685%2064676"
value="+4971168564676" target="_blank">+49 711 685 64676</a><br>
IWS, Universität Stuttgart fax: <a
moz-do-not-send="true"
href="tel:%2B49%20711%20685%2060430"
value="+4971168560430" target="_blank">+49 711 685 60430</a><br>
Pfaffenwaldring 61 email: <a
moz-do-not-send="true"
href="mailto:timo.koch@iws.uni-stuttgart.de"
target="_blank"><a class="moz-txt-link-abbreviated" href="mailto:timo.koch@iws.uni-stuttgart.de">timo.koch@iws.uni-stuttgart.de</a></a><br>
D-70569 Stuttgart url: <a
moz-do-not-send="true"
href="http://www.hydrosys.uni-stuttgart.de"
rel="noreferrer" target="_blank"><a class="moz-txt-link-abbreviated" href="http://www.hydrosys.uni-stuttgart.de">www.hydrosys.uni-stuttgart.de</a></a><br>
____________________________________________________________________<br>
<br>
<br>
_______________________________________________<br>
Dune-devel mailing list<br>
<a moz-do-not-send="true"
href="mailto:Dune-devel@dune-project.org" target="_blank">Dune-devel@dune-project.org</a><br>
<a moz-do-not-send="true"
href="http://lists.dune-project.org/mailman/listinfo/dune-devel"
rel="noreferrer" target="_blank">http://lists.dune-project.org/mailman/listinfo/dune-devel</a><br>
</blockquote>
</div>
<br>
</div>
</blockquote>
<br>
<pre class="moz-signature" cols="72">--
____________________________________________________________________
Timo Koch phone: +49 711 685 64676
IWS, Universität Stuttgart fax: +49 711 685 60430
Pfaffenwaldring 61 email: <a class="moz-txt-link-abbreviated" href="mailto:timo.koch@iws.uni-stuttgart.de">timo.koch@iws.uni-stuttgart.de</a>
D-70569 Stuttgart url: <a class="moz-txt-link-abbreviated" href="http://www.hydrosys.uni-stuttgart.de">www.hydrosys.uni-stuttgart.de</a>
____________________________________________________________________</pre>
</body>
</html>