[dune-pdelab] autoconf error during installation

Markus Blatt Markus.Blatt at web.de
Thu Sep 15 20:05:15 CEST 2011


Hey,

just to be sure: There is a libtool version installed on your computer?

Markus

On 15.09.2011, at 17:49, Eike Mueller wrote:

> Dear pdelab list,
>
> I'm trying to build pdelab (I downloaded the version compatible with  
> dune 2.1) with
>
> ./dune-common-2.1.0/bin/dunecontrol --only=dune-pdelab -- 
> opts=config.opts all
>
> and autoconf falls over with the following error message:
>
> configure:6468: error: possibly undefined macro: AC_DISABLE_SHARED
>     If this token and others are legitimate, please use  
> m4_pattern_allow.
>     See the Autoconf documentation.
> configure:6469: error: possibly undefined macro: AC_PROG_LIBTOOL
> configure:17090: error: possibly undefined macro: AC_PROG_LD_GNU
> --- Failed to build dune-pdelab ---
> Terminating dunecontrol due to previous errors!
>
> I had to install my own copies of autoconf and automake and the file  
> config.opts has the following contents:
>
> AUTOGEN_FLAGS="--ac=2.61 --am=1.10"
> CONFIGURE_FLAGS="--prefix='/home/em459/Dune/' --enable-parallel -- 
> disable-documentation"
> MAKE_FLAGS=
>
> Could anyone point me to a fix for this problem?
>
> Thank you very much,
>
> Eike
>
> _______________________________________________
> dune-pdelab mailing list
> dune-pdelab at dune-project.org
> http://lists.dune-project.org/mailman/listinfo/dune-pdelab
>




More information about the dune-pdelab mailing list