[Dune] [#674] strict-aliasing warnings with gcc-4.4

Dune dune at dune-project.org
Sun Dec 6 19:28:51 CET 2009


THIS IS AN AUTOMATED MESSAGE, DO NOT REPLY.

The following task has a new comment added:

FS#674 - strict-aliasing warnings with gcc-4.4
User who did this - Carsten Gräser (Carsten)

----------
Of course you can do this - but this means you have to change your code. It is furthermore no argument against my suggestion since you can then also do

template<class It>
foo(It& it)

and would never need to get the EP& and thus to update the second HostEP. BTW: No one wants to make meta grids slow. Is there any performance argument against my suggestion to update the stored HostEP& only if needed ?
----------

More information can be found at the following URL:
http://www.dune-project.org/flyspray/index.php?do=details&task_id=674#comment1465

You are receiving this message because you have requested it from the Flyspray bugtracking system.  If you did not expect this message or don't want to receive mails in future, you can change your notification settings at the URL shown above.



More information about the Dune mailing list