[Dune] [#503] Consistent naming for grid view access

Dune flyspray at dune-project.org
Thu Dec 17 12:52:25 CET 2009


The following task has a new comment added:

FS#503 - Consistent naming for grid view access
User who did this - Martin Nolte (nolte)

If we rename them at all, I would suggest to rename the types, since they are less frequently used. We should, however, keep in mind that this causes some code changing. For this reason, I agree with Mario: Do the costs really outweigh the benefits?

By the way: I think there are more places to which this argument applies:
- method lbegin / lend instead of levelbegin while the iterator is called LevelIterator instead on LIterator
- method ibegin / iend instead of intersectionBegin while iterator is called IntersectionIterator instead of IIterator
- method hbegin / hend instead of hierarchicBegin while iterator is called HierarchicIterator instead of HIterator
- method comm instead of collectiveCommunication while the object is of type CollectiveCommunication instead of Comm


More information can be found at the following URL:

You are receiving this message because you have requested it from the Flyspray bugtracking system.  If you did not expect this message or don't want to receive mails in future, you can change your notification settings at the URL shown above.

More information about the Dune mailing list