[Dune] [#674] strict-aliasing warnings with gcc-4.4

Dune flyspray at dune-project.org
Fri Dec 18 11:51:08 CET 2009


THIS IS AN AUTOMATED MESSAGE, DO NOT REPLY.

The following task has a new comment added:

FS#674 - strict-aliasing warnings with gcc-4.4
User who did this - Christian Engwer (christi)

----------
I don't think we must have a aliasing-free 2.0 release, but must somehow react to this problem.

We can either fix this, or we state explicitly that aliasing is a problem and that dune _must_ be compiled with -fno-strict-aliasing.

In any case I would try to reduce the problematic parts as far as possible.

In this sense the task is a show stopper. Without a fix or a clear statement... no release.
----------

More information can be found at the following URL:
http://www.dune-project.org/flyspray/index.php?do=details&task_id=674#comment1584

You are receiving this message because you have requested it from the Flyspray bugtracking system.  If you did not expect this message or don't want to receive mails in future, you can change your notification settings at the URL shown above.



More information about the Dune mailing list