[Dune] dgfgridtype.hh confuses me

Christoph Grüninger christoph.grueninger at iws.uni-stuttgart.de
Wed Mar 7 09:21:30 CET 2012


Dear Dune,
my colleague stumbled over a documentation flaw. I investigated the 
situation and got confused by /dune/grid/io/file/dgfparserdgfgridtype.hh

===
#ifndef DUNE_DGFGRIDTYPE_HH
#define DUNE_DGFGRIDTYPE_HH

#warning "<dune/grid/io/file/dgfgridtype.hh> has been deprecated."
#warning "It suffices to include config.h."

#include <dune/grid/utility/gridtype.hh>

#endif
===

Either it is sufficient to include config.h and we can drop the 
inclusion of gridtype.hh or it is not and the warning is not right. 
What's the case?

Thanks
Christoph

-- 
Actually, most flamewars are caused
by Vim being much worse than Emacs.
[http://science.slashdot.org/comments.pl?sid=177208&cid=14705579]



More information about the Dune mailing list