[Dune] SuperLU with CMake

Gergely Schmidt schmidt at hydromech.uni-hannover.de
Mon Feb 13 16:47:36 CET 2017


Hello everybody,

thanks for the answers to Christoph and Dominic!

Setting the DSUPERLU_INCLUDE_DIR and DSUPERLU_LIBRARY flags should work, 
but SuperLU is still not found and I get the warning “Manually-specified 
variables were not used by the project: SUPERLU_INCLUDE_DIR 
SUPERLU_LIBRARY” for each module dunecontrol builds (I double-checked 
the paths I pass to these two flags).

I’m sorry, but what is the question “Have you tried the packages from 
your distribution or homebrew?” referring to?

Is there another CMake flag which should be set besides 
DSUPERLU_INCLUDE_DIR and DSUPERLU_LIBRARY?

I have an Ubuntu 16.04 LTS distribution, have g++ 5.4.0, cmake 3.5.1, 
gfortran 5.4.0, automake 1.15 and libtool 2.4.6 installed and I have 
tested SuperLU with “make test” without errors. Did I miss to install 
some prerequisite software?

Kind regards and many thanks!
Gergő

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.dune-project.org/pipermail/dune/attachments/20170213/32b968f6/attachment-0001.html>


More information about the Dune mailing list