[Dune] Dune Release 1.2 configure crashes early on in dune-common

Martin Nolte nolte at mathematik.uni-freiburg.de
Mon Feb 16 14:53:44 CET 2009


Error was in trunk, too. Fixed since 5430. Merge corresponding change to release.

Benedikt Oswald wrote:
> Dear Dune, the configure of Dune Release 1.2 crashes with the following error message, cf. end of output:
> 
> =================================================
> [oswald at merlin00 dune-1.2]$ uname -a
> Linux merlin00 2.6.9-78.0.1.ELsmp #1 SMP Tue Aug 5 13:53:03 CDT 2008 x86_64 x86_64 x86_64 GNU/Linux
> ===================================================
> 
> I am not sure on where to search for the error:
> 
> I have installed the following versions of autoconf and automake:
> 
> =====================================================================
> [oswald at merlin00 dune-1.2]$ autoconf --version
> autoconf (GNU Autoconf) 2.63
> Copyright (C) 2008 Free Software Foundation, Inc.
> License GPLv2+: GNU GPL version 2 or later
> <http://gnu.org/licenses/old-licenses/gpl-2.0.html>
> This is free software: you are free to change and redistribute it.
> There is NO WARRANTY, to the extent permitted by law.
> =====================================================================
> 
> 
> 
> ===================================================
> [oswald at merlin00 dune-1.2]$ automake --version
> automake (GNU automake) 1.9.2
> Written by Tom Tromey <tromey at redhat.com>.
> ==================================================
> 
> 
> 
> [oswald at merlin00 dune-1.2]$ ./dune-common/bin/dunecontrol --opts=dune.psi.opts all
> --- going to build dune-common dune-grid dune-istl dune-grid-howto hades  ---
> --- calling all for dune-common ---
> --- calling autogen for dune-common ---
> Found am directory /home2/oswald/scratch2-svnwork-merlin/dune-1.2/dune-common/am
> --> libtoolize...
> Remember to add `AC_PROG_LIBTOOL' to `configure.ac'.
> --> writing dependencies.m4
>     for dune-common 1.2 dune at dune-project.org
>         requires
> --> aclocal...
> /usr/share/aclocal/libgcrypt.m4:23: warning: underquoted definition of AM_PATH_LIBGCRYPT
>   run info '(automake)Extending aclocal'
>   or see http://sources.redhat.com/automake/automake.html#Extending-aclocal
> configure.ac:15: warning: PKG_PROG_PKG_CONFIG is m4_require'd but not m4_defun'd
> dependencies.m4:17: DUNE_CHECK_MOD_DEPENDENCIES is expanded from...
> /home2/oswald/scratch2-svnwork-merlin/dune-1.2/dune-common/m4/dune_all.m4:19: DUNE_CHECK_ALL is expanded from...
> configure.ac:15: the top level
> configure.ac:15: warning: AC_CACHE_VAL(lt_prog_compiler_static_works, ...): suspicious cache-id, must contain _cv_ to be cached
> ../../lib/autoconf/general.m4:1974: AC_CACHE_VAL is expanded from...
> ../../lib/autoconf/general.m4:1994: AC_CACHE_CHECK is expanded from...
> /usr/share/aclocal/libtool.m4:609: AC_LIBTOOL_LINKER_OPTION is expanded from...
> /usr/share/aclocal/libtool.m4:2486: _LT_AC_LANG_C_CONFIG is expanded from...
> /usr/share/aclocal/libtool.m4:2485: AC_LIBTOOL_LANG_C_CONFIG is expanded from...
> /usr/share/aclocal/libtool.m4:95: AC_LIBTOOL_SETUP is expanded from...
> /usr/share/aclocal/libtool.m4:75: _AC_PROG_LIBTOOL is expanded from...
> /usr/share/aclocal/libtool.m4:40: AC_PROG_LIBTOOL is expanded from...
> configure.ac:15: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works, ...): suspicious cache-id, must contain _cv_ to be cached
> /usr/share/aclocal/libtool.m4:566: AC_LIBTOOL_COMPILER_OPTION is expanded from...
> /usr/share/aclocal/libtool.m4:4540: AC_LIBTOOL_PROG_COMPILER_PIC is expanded from...
> configure.ac:15: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works_CXX, ...): suspicious cache-id, must contain _cv_ to be cached
> /usr/share/aclocal/libtool.m4:2631: _LT_AC_LANG_CXX_CONFIG is expanded from...
> /usr/share/aclocal/libtool.m4:2630: AC_LIBTOOL_LANG_CXX_CONFIG is expanded from...
> /usr/share/aclocal/libtool.m4:1647: _LT_AC_TAGCONFIG is expanded from...
> configure.ac:15: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works_F77, ...): suspicious cache-id, must contain _cv_ to be cached
> /usr/share/aclocal/libtool.m4:3661: _LT_AC_LANG_F77_CONFIG is expanded from...
> /usr/share/aclocal/libtool.m4:3660: AC_LIBTOOL_LANG_F77_CONFIG is expanded from...
> configure.ac:15: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works_GCJ, ...): suspicious cache-id, must contain _cv_ to be cached
> /usr/share/aclocal/libtool.m4:3761: _LT_AC_LANG_GCJ_CONFIG is expanded from...
> /usr/share/aclocal/libtool.m4:3760: AC_LIBTOOL_LANG_GCJ_CONFIG is expanded from...
> /home2/oswald/scratch2-svnwork-merlin/dune-1.2/dune-common/m4/dune_common.m4:1: DUNE_COMMON_CHECKS is expanded from...
> --> autoheader...
> configure.ac:15: warning: PKG_PROG_PKG_CONFIG is m4_require'd but not m4_defun'd
> dependencies.m4:17: DUNE_CHECK_MOD_DEPENDENCIES is expanded from...
> aclocal.m4:7435: DUNE_CHECK_ALL is expanded from...
> configure.ac:15: the top level
> configure.ac:15: warning: AC_CACHE_VAL(lt_prog_compiler_static_works, ...): suspicious cache-id, must contain _cv_ to be cached
> ../../lib/autoconf/general.m4:1974: AC_CACHE_VAL is expanded from...
> ../../lib/autoconf/general.m4:1994: AC_CACHE_CHECK is expanded from...
> aclocal.m4:600: AC_LIBTOOL_LINKER_OPTION is expanded from...
> aclocal.m4:2477: _LT_AC_LANG_C_CONFIG is expanded from...
> aclocal.m4:2476: AC_LIBTOOL_LANG_C_CONFIG is expanded from...
> aclocal.m4:86: AC_LIBTOOL_SETUP is expanded from...
> aclocal.m4:66: _AC_PROG_LIBTOOL is expanded from...
> aclocal.m4:31: AC_PROG_LIBTOOL is expanded from...
> configure.ac:15: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works, ...): suspicious cache-id, must contain _cv_ to be cached
> aclocal.m4:557: AC_LIBTOOL_COMPILER_OPTION is expanded from...
> aclocal.m4:4519: AC_LIBTOOL_PROG_COMPILER_PIC is expanded from...
> configure.ac:15: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works_CXX, ...): suspicious cache-id, must contain _cv_ to be cached
> aclocal.m4:2618: _LT_AC_LANG_CXX_CONFIG is expanded from...
> aclocal.m4:2617: AC_LIBTOOL_LANG_CXX_CONFIG is expanded from...
> aclocal.m4:1638: _LT_AC_TAGCONFIG is expanded from...
> configure.ac:15: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works_F77, ...): suspicious cache-id, must contain _cv_ to be cached
> aclocal.m4:3644: _LT_AC_LANG_F77_CONFIG is expanded from...
> aclocal.m4:3643: AC_LIBTOOL_LANG_F77_CONFIG is expanded from...
> configure.ac:15: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works_GCJ, ...): suspicious cache-id, must contain _cv_ to be cached
> aclocal.m4:3744: _LT_AC_LANG_GCJ_CONFIG is expanded from...
> aclocal.m4:3743: AC_LIBTOOL_LANG_GCJ_CONFIG is expanded from...
> aclocal.m4:7530: DUNE_COMMON_CHECKS is expanded from...
> --> automake...
> configure.ac:15: warning: PKG_PROG_PKG_CONFIG is m4_require'd but not m4_defun'd
> dependencies.m4:17: DUNE_CHECK_MOD_DEPENDENCIES is expanded from...
> aclocal.m4:7435: DUNE_CHECK_ALL is expanded from...
> configure.ac:15: the top level
> configure.ac:15: warning: AC_CACHE_VAL(lt_prog_compiler_static_works, ...): suspicious cache-id, must contain _cv_ to be cached
> ../../lib/autoconf/general.m4:1974: AC_CACHE_VAL is expanded from...
> ../../lib/autoconf/general.m4:1994: AC_CACHE_CHECK is expanded from...
> aclocal.m4:600: AC_LIBTOOL_LINKER_OPTION is expanded from...
> aclocal.m4:2477: _LT_AC_LANG_C_CONFIG is expanded from...
> aclocal.m4:2476: AC_LIBTOOL_LANG_C_CONFIG is expanded from...
> aclocal.m4:86: AC_LIBTOOL_SETUP is expanded from...
> aclocal.m4:66: _AC_PROG_LIBTOOL is expanded from...
> aclocal.m4:31: AC_PROG_LIBTOOL is expanded from...
> configure.ac:15: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works, ...): suspicious cache-id, must contain _cv_ to be cached
> aclocal.m4:557: AC_LIBTOOL_COMPILER_OPTION is expanded from...
> aclocal.m4:4519: AC_LIBTOOL_PROG_COMPILER_PIC is expanded from...
> configure.ac:15: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works_CXX, ...): suspicious cache-id, must contain _cv_ to be cached
> aclocal.m4:2618: _LT_AC_LANG_CXX_CONFIG is expanded from...
> aclocal.m4:2617: AC_LIBTOOL_LANG_CXX_CONFIG is expanded from...
> aclocal.m4:1638: _LT_AC_TAGCONFIG is expanded from...
> configure.ac:15: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works_F77, ...): suspicious cache-id, must contain _cv_ to be cached
> aclocal.m4:3644: _LT_AC_LANG_F77_CONFIG is expanded from...
> aclocal.m4:3643: AC_LIBTOOL_LANG_F77_CONFIG is expanded from...
> configure.ac:15: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works_GCJ, ...): suspicious cache-id, must contain _cv_ to be cached
> aclocal.m4:3744: _LT_AC_LANG_GCJ_CONFIG is expanded from...
> aclocal.m4:3743: AC_LIBTOOL_LANG_GCJ_CONFIG is expanded from...
> aclocal.m4:7530: DUNE_COMMON_CHECKS is expanded from...
> doc/doxygen/Makefile.am:10: WHAT was already defined in condition TRUE, which includes condition BUILD_DOCS and WML ...
> doc/doxygen/Makefile.am:6: ... `WHAT' previously defined here
> am/doxygen:70: user target `html' defined here...
> doc/doxygen/Makefile.am:22:   `am/doxygen' included from here
> automake: ... overrides Automake target `html' defined here
> am/doxygen:70: consider using html-local instead of html
> doc/doxygen/Makefile.am:22:   `am/doxygen' included from here
> --> autoconf...
> configure.ac:15: warning: PKG_PROG_PKG_CONFIG is m4_require'd but not m4_defun'd
> dependencies.m4:17: DUNE_CHECK_MOD_DEPENDENCIES is expanded from...
> aclocal.m4:7435: DUNE_CHECK_ALL is expanded from...
> configure.ac:15: the top level
> configure.ac:15: warning: AC_CACHE_VAL(lt_prog_compiler_static_works, ...): suspicious cache-id, must contain _cv_ to be cached
> ../../lib/autoconf/general.m4:1974: AC_CACHE_VAL is expanded from...
> ../../lib/autoconf/general.m4:1994: AC_CACHE_CHECK is expanded from...
> aclocal.m4:600: AC_LIBTOOL_LINKER_OPTION is expanded from...
> aclocal.m4:2477: _LT_AC_LANG_C_CONFIG is expanded from...
> aclocal.m4:2476: AC_LIBTOOL_LANG_C_CONFIG is expanded from...
> aclocal.m4:86: AC_LIBTOOL_SETUP is expanded from...
> aclocal.m4:66: _AC_PROG_LIBTOOL is expanded from...
> aclocal.m4:31: AC_PROG_LIBTOOL is expanded from...
> configure.ac:15: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works, ...): suspicious cache-id, must contain _cv_ to be cached
> aclocal.m4:557: AC_LIBTOOL_COMPILER_OPTION is expanded from...
> aclocal.m4:4519: AC_LIBTOOL_PROG_COMPILER_PIC is expanded from...
> configure.ac:15: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works_CXX, ...): suspicious cache-id, must contain _cv_ to be cached
> aclocal.m4:2618: _LT_AC_LANG_CXX_CONFIG is expanded from...
> aclocal.m4:2617: AC_LIBTOOL_LANG_CXX_CONFIG is expanded from...
> aclocal.m4:1638: _LT_AC_TAGCONFIG is expanded from...
> configure.ac:15: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works_F77, ...): suspicious cache-id, must contain _cv_ to be cached
> aclocal.m4:3644: _LT_AC_LANG_F77_CONFIG is expanded from...
> aclocal.m4:3643: AC_LIBTOOL_LANG_F77_CONFIG is expanded from...
> configure.ac:15: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works_GCJ, ...): suspicious cache-id, must contain _cv_ to be cached
> aclocal.m4:3744: _LT_AC_LANG_GCJ_CONFIG is expanded from...
> aclocal.m4:3743: AC_LIBTOOL_LANG_GCJ_CONFIG is expanded from...
> aclocal.m4:7530: DUNE_COMMON_CHECKS is expanded from...
> Now run ./configure to setup dune-common
> --- calling configure for dune-common ---
> ----- using default flags $CONFIGURE_FLAGS from /home2/oswald/scratch2-svnwork-merlin/dune-1.2/dune.psi.opts -----
> ./configure CXX='mpicxx' CC='mpicxx' LD='mpicxx' CXXFLAGS='-DMPICH_IGNORE_CXX_SEEK ' CPPFLAGS='-DMPICH_IGNORE_CXX_SEEK ' LDFLAGS='-lgfortran /usr/lib64/libblas.so.3.1.1 '
> LTFLAGS='-all-static ' --enable-experimental-hades3deld --disable-shared --enable-static --disable-documentation --enable-parallel --enable-boost
> --with-boost='/scratch2/amas/oswald/extlib/merlin/boost-1.37.0' --enable-debug-high --enable-message-high
> --with-trilinos='/scratch2/amas/oswald/extlib/merlin/trilinos-9.0.1-openmpi-1.2.5' --enable-trilinos-solver --with-geoexporter='/scratch2/amas/oswald/ownlib/merlin/faraday/euklid'
> --prefix='/scratch2/amas/oswald/ownlib/merlin/hades' --with-metis='/scratch2/amas/oswald/extlib/merlin/metis-4.0'
> --with-alugrid='/scratch2/amas/oswald/extlib/merlin/ALUGrid-1.14-openmpi-1.2.5' --with-rlog='/scratch2/amas/oswald/extlib/merlin/rlog-1.4'
> "--with-dune-common=/home2/oswald/scratch2-svnwork-merlin/dune-1.2/dune-common" "--with-dune-grid=/home2/oswald/scratch2-svnwork-merlin/dune-1.2/dune-grid"
> "--with-dune-istl=/home2/oswald/scratch2-svnwork-merlin/dune-1.2/dune-istl" "--with-dune-grid-howto=/home2/oswald/scratch2-svnwork-merlin/dune-1.2/dune-grid-howto"
> "--with-hades=/home2/oswald/scratch2-svnwork-merlin/dune-1.2/hades" ACLOCAL_AMFLAGS="-I . -I /home2/oswald/scratch2-svnwork-merlin/dune-1.2/dune-common/m4 -I
> /home2/oswald/scratch2-svnwork-merlin/dune-1.2/dune-grid/m4 -I /home2/oswald/scratch2-svnwork-merlin/dune-1.2/dune-istl/m4"
> configure: WARNING: unrecognized options: --enable-experimental-hades3deld, --enable-boost, --with-boost, --enable-debug-high, --enable-message-high, --with-trilinos,
> --enable-trilinos-solver, --with-geoexporter, --with-metis, --with-alugrid, --with-rlog, --with-dune-common, --with-dune-grid, --with-dune-istl, --with-dune-grid-howto, --with-hades
> checking for gawk... gawk
> checking for a BSD-compatible install... /usr/bin/install -c
> checking whether build environment is sane... yes
> checking whether make sets $(MAKE)... yes
> checking whether ln -s works... yes
> HOSTID:
> ./configure: line 2849: PKG_PROG_PKG_CONFIG: command not found
> checking for style of include used by make... GNU
> checking for gcc... mpicxx
> checking for C compiler default output file name... a.out
> checking whether the C compiler works... yes
> checking whether we are cross compiling... no
> checking for suffix of executables...
> checking for suffix of object files... o
> checking whether we are using the GNU C compiler... yes
> checking whether mpicxx accepts -g... yes
> checking for mpicxx option to accept ISO C89... unsupported
> checking dependency style of mpicxx... gcc3
> checking how to run the C preprocessor... mpicxx -E
> checking whether we are using the GNU C++ compiler... yes
> checking whether mpicxx accepts -g... yes
> checking dependency style of mpicxx... gcc3
> checking how to run the C++ preprocessor... mpicxx -E
> checking build system type... x86_64-redhat-linux-gnu
> checking host system type... x86_64-redhat-linux-gnu
> checking for a sed that does not truncate output... /bin/sed
> checking for grep that handles long lines and -e... /bin/grep
> checking for egrep... /bin/grep -E
> checking for ld used by mpicxx... mpicxx
> checking if the linker (mpicxx) is GNU ld... no
> checking for mpicxx option to reload object files... -r
> checking for BSD-compatible nm... /usr/bin/nm -B
> checking how to recognise dependent libraries... pass_all
> checking for ANSI C header files... yes
> checking for sys/types.h... yes
> checking for sys/stat.h... yes
> checking for stdlib.h... yes
> checking for string.h... yes
> checking for memory.h... yes
> checking for strings.h... yes
> checking for inttypes.h... yes
> checking for stdint.h... yes
> checking for unistd.h... yes
> checking dlfcn.h usability... yes
> checking dlfcn.h presence... yes
> checking for dlfcn.h... yes
> checking whether we are using the GNU Fortran 77 compiler... yes
> checking whether mpif77 accepts -g... yes
> checking the maximum length of command line arguments... 32768
> checking command to parse /usr/bin/nm -B output from mpicxx object... ok
> checking for objdir... .libs
> checking for ar... ar
> checking for ranlib... ranlib
> checking for strip... strip
> checking if mpicxx static flag  works... no
> checking if mpicxx supports -fno-rtti -fno-exceptions... yes
> checking for mpicxx option to produce PIC... -fPIC
> checking if mpicxx PIC flag -fPIC works... yes
> checking if mpicxx supports -c -o file.o... yes
> checking whether the mpicxx linker (mpicxx -m elf_x86_64) supports shared libraries... no
> checking dynamic linker characteristics... GNU/Linux ld.so
> checking how to hardcode library paths into programs... immediate
> checking whether stripping libraries is possible... yes
> checking if libtool supports shared libraries... no
> checking whether to build shared libraries... no
> checking whether to build static libraries... yes
> configure: creating libtool
> appending configuration tag "CXX" to libtool
> checking for ld used by mpicxx... mpicxx -m elf_x86_64
> checking if the linker (mpicxx -m elf_x86_64) is GNU ld... no
> checking whether the mpicxx linker (mpicxx -m elf_x86_64) supports shared libraries... yes
> checking for mpicxx option to produce PIC... -fPIC
> checking if mpicxx PIC flag -fPIC works... yes
> checking if mpicxx supports -c -o file.o... yes
> checking whether the mpicxx linker (mpicxx -m elf_x86_64) supports shared libraries... yes
> checking dynamic linker characteristics... GNU/Linux ld.so
> checking how to hardcode library paths into programs... immediate
> checking whether stripping libraries is possible... yes
> appending configuration tag "F77" to libtool
> checking if libtool supports shared libraries... no
> checking whether to build shared libraries... no
> checking whether to build static libraries... yes
> checking for mpif77 option to produce PIC... -fPIC
> checking if mpif77 PIC flag -fPIC works... yes
> checking if mpif77 supports -c -o file.o... yes
> checking whether the mpif77 linker (mpicxx -m elf_x86_64) supports shared libraries... no
> checking dynamic linker characteristics... GNU/Linux ld.so
> checking how to hardcode library paths into programs... immediate
> checking whether stripping libraries is possible... yes
> ./configure: line 20252: PKG_PROG_PKG_CONFIG: command not found
> checking for ranlib... (cached) ranlib
> checking whether g++ accepts -std=c++0x... no
> checking whether static_assert is supported... no
> checking whether nullptr is supported... no
> checking whether compiling C++ code works... yes
> checking whether linking C++ objects works... yes
> checking for __attribute__((deprecated))... yes
> checking rpc/rpc.h usability... yes
> checking rpc/rpc.h presence... yes
> checking for rpc/rpc.h... yes
> checking for mpicc... mpicc
> checking for MPI_Init... yes
> checking for mpi.h... yes
> configure: Trying to identify the version of MPI compiler mpicc
> checking for lam... no
> checking for mpich... no
> checking for OpenMPI... yes
> checking whether compiling with OpenMPI works... yes
> checking whether running with OpenMPI works... yes
> checking for MPI_Finalized in -lm... yes
> checking for an ANSI C-conforming const... yes
> checking for inline... inline
> checking for size_t... yes
> checking whether struct tm is in sys/time.h or time.h... time.h
> checking for stdlib.h... (cached) yes
> checking for GNU libc compatible malloc... yes
> checking for inkscape... no
> checking malloc.h usability... yes
> checking malloc.h presence... yes
> checking for malloc.h... yes
> checking for string.h... (cached) yes
> ./configure: line 22904: syntax error near unexpected token `array'
> ./configure: line 22904: `                        array tr1/array tuple tr1/tuple'
> --- Failed to build dune-common ---
> Execution of dunecontrol terminated due to errors!
> 
> 
> 
> 
> 
> 
> 
> 

-- 
Martin Nolte <nolte at mathematik.uni-freiburg.de>

Universität Freiburg                                   phone: +49-761-203-5642
Abteilung für angewandte Mathematik                    fax:   +49-761-203-5632
Hermann-Herder-Straße 10
79104 Freiburg, Germany



More information about the Dune mailing list