[Dune] Dune Release 1.2 configure crashes early on in dune-common

Benedikt Oswald benedikt.oswald at psi.ch
Mon Feb 16 16:12:42 CET 2009


Hi Martin, thanks, but still, if I do an update in dune-commen (svn update)
then it crashes, however differently, cf. at the end of the mail.

Greetings, Benedikt


[oswald at merlin00 dune-1.2]$ ./dune-common/bin/dunecontrol --opts=dune.psi.opts all
--- going to build dune-common dune-grid dune-istl dune-grid-howto hades  ---
--- calling all for dune-common ---
--- calling autogen for dune-common ---
Found am directory /home2/oswald/scratch2-svnwork-merlin/dune-1.2/dune-common/am
--> libtoolize...
libtoolize: putting auxiliary files in `.'.
libtoolize: linking file `./ltmain.sh'
libtoolize: You should add the contents of the following files to `aclocal.m4':
libtoolize:   `/home2/oswald/scratch2-extlib-merlin/libtool-2.2.6/share/aclocal/libtool.m4'
libtoolize:   `/home2/oswald/scratch2-extlib-merlin/libtool-2.2.6/share/aclocal/ltoptions.m4'
libtoolize:   `/home2/oswald/scratch2-extlib-merlin/libtool-2.2.6/share/aclocal/ltversion.m4'
libtoolize:   `/home2/oswald/scratch2-extlib-merlin/libtool-2.2.6/share/aclocal/ltsugar.m4'
libtoolize:   `/home2/oswald/scratch2-extlib-merlin/libtool-2.2.6/share/aclocal/lt~obsolete.m4'
libtoolize: Remember to add `LT_INIT' to configure.ac.
libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.ac and
libtoolize: rerunning libtoolize, to keep the correct libtool macros in-tree.
libtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am.
--> writing dependencies.m4
    for dune-common 1.2 dune at dune-project.org
        requires
--> aclocal...
configure.ac:15: warning: PKG_PROG_PKG_CONFIG is m4_require'd but not m4_defun'd
dependencies.m4:17: DUNE_CHECK_MOD_DEPENDENCIES is expanded from...
/home2/oswald/scratch2-svnwork-merlin/dune-1.2/dune-common/m4/dune_all.m4:19: DUNE_CHECK_ALL is expanded from...
configure.ac:15: the top level
configure.ac:15: warning: AC_PROG_LIBTOOL is m4_require'd but not m4_defun'd
/home2/oswald/scratch2-svnwork-merlin/dune-1.2/dune-common/m4/dune_common.m4:1: DUNE_COMMON_CHECKS is expanded from...
--> autoheader...
configure.ac:15: warning: PKG_PROG_PKG_CONFIG is m4_require'd but not m4_defun'd
dependencies.m4:17: DUNE_CHECK_MOD_DEPENDENCIES is expanded from...
aclocal.m4:1355: DUNE_CHECK_ALL is expanded from...
configure.ac:15: the top level
configure.ac:15: warning: AC_PROG_LIBTOOL is m4_require'd but not m4_defun'd
aclocal.m4:1450: DUNE_COMMON_CHECKS is expanded from...
--> automake...
configure.ac:15: warning: PKG_PROG_PKG_CONFIG is m4_require'd but not m4_defun'd
dependencies.m4:17: DUNE_CHECK_MOD_DEPENDENCIES is expanded from...
aclocal.m4:1355: DUNE_CHECK_ALL is expanded from...
configure.ac:15: the top level
configure.ac:15: warning: AC_PROG_LIBTOOL is m4_require'd but not m4_defun'd
aclocal.m4:1450: DUNE_COMMON_CHECKS is expanded from...
common/Makefile.am:6: Libtool library used but `LIBTOOL' is undefined
common/Makefile.am:6:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
common/Makefile.am:6:   to `configure.ac' and run `aclocal' and `autoconf' again.
common/Makefile.am:6:   If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
common/Makefile.am:6:   its definition is in aclocal's search path.
doc/doxygen/Makefile.am:10: WHAT was already defined in condition TRUE, which includes condition BUILD_DOCS and WML ...
doc/doxygen/Makefile.am:6: ... `WHAT' previously defined here
am/doxygen:70: user target `html' defined here...
doc/doxygen/Makefile.am:22:   `am/doxygen' included from here
automake: ... overrides Automake target `html' defined here
am/doxygen:70: consider using html-local instead of html
doc/doxygen/Makefile.am:22:   `am/doxygen' included from here
lib/Makefile.am:4: Libtool library used but `LIBTOOL' is undefined
lib/Makefile.am:4:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
lib/Makefile.am:4:   to `configure.ac' and run `aclocal' and `autoconf' again.
lib/Makefile.am:4:   If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
lib/Makefile.am:4:   its definition is in aclocal's search path.
--- Failed to build dune-common ---
Execution of dunecontrol terminated due to errors!
[oswald at merlin00 dune-1.2]$ ./dune-common/bin/dunecontrol --opts=dune.psi.opts all
--- going to build dune-common dune-grid dune-istl dune-grid-howto hades  ---
--- calling all for dune-common ---
--- calling autogen for dune-common ---
Found am directory /home2/oswald/scratch2-svnwork-merlin/dune-1.2/dune-common/am
--> libtoolize...
libtoolize: putting auxiliary files in `.'.
libtoolize: linking file `./ltmain.sh'
libtoolize: You should add the contents of the following files to `aclocal.m4':
libtoolize:   `/home2/oswald/scratch2-extlib-merlin/libtool-2.2.6/share/aclocal/libtool.m4'
libtoolize:   `/home2/oswald/scratch2-extlib-merlin/libtool-2.2.6/share/aclocal/ltoptions.m4'
libtoolize:   `/home2/oswald/scratch2-extlib-merlin/libtool-2.2.6/share/aclocal/ltversion.m4'
libtoolize:   `/home2/oswald/scratch2-extlib-merlin/libtool-2.2.6/share/aclocal/ltsugar.m4'
libtoolize:   `/home2/oswald/scratch2-extlib-merlin/libtool-2.2.6/share/aclocal/lt~obsolete.m4'
libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.ac and
libtoolize: rerunning libtoolize, to keep the correct libtool macros in-tree.
libtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am.
--> writing dependencies.m4
    for dune-common 1.2 dune at dune-project.org
        requires
--> aclocal...
configure.ac:17: warning: PKG_PROG_PKG_CONFIG is m4_require'd but not m4_defun'd
dependencies.m4:17: DUNE_CHECK_MOD_DEPENDENCIES is expanded from...
/home2/oswald/scratch2-svnwork-merlin/dune-1.2/dune-common/m4/dune_all.m4:19: DUNE_CHECK_ALL is expanded from...
configure.ac:17: the top level
configure.ac:17: warning: AC_PROG_LIBTOOL is m4_require'd but not m4_defun'd
/home2/oswald/scratch2-svnwork-merlin/dune-1.2/dune-common/m4/dune_common.m4:1: DUNE_COMMON_CHECKS is expanded from...
--> autoheader...
configure.ac:17: warning: PKG_PROG_PKG_CONFIG is m4_require'd but not m4_defun'd
dependencies.m4:17: DUNE_CHECK_MOD_DEPENDENCIES is expanded from...
aclocal.m4:1355: DUNE_CHECK_ALL is expanded from...
configure.ac:17: the top level
configure.ac:17: warning: AC_PROG_LIBTOOL is m4_require'd but not m4_defun'd
aclocal.m4:1450: DUNE_COMMON_CHECKS is expanded from...
--> automake...
configure.ac:17: warning: PKG_PROG_PKG_CONFIG is m4_require'd but not m4_defun'd
dependencies.m4:17: DUNE_CHECK_MOD_DEPENDENCIES is expanded from...
aclocal.m4:1355: DUNE_CHECK_ALL is expanded from...
configure.ac:17: the top level
configure.ac:17: warning: AC_PROG_LIBTOOL is m4_require'd but not m4_defun'd
aclocal.m4:1450: DUNE_COMMON_CHECKS is expanded from...
common/Makefile.am:6: Libtool library used but `LIBTOOL' is undefined
common/Makefile.am:6:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
common/Makefile.am:6:   to `configure.ac' and run `aclocal' and `autoconf' again.
common/Makefile.am:6:   If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
common/Makefile.am:6:   its definition is in aclocal's search path.
doc/doxygen/Makefile.am:10: WHAT was already defined in condition TRUE, which includes condition BUILD_DOCS and WML ...
doc/doxygen/Makefile.am:6: ... `WHAT' previously defined here
am/doxygen:70: user target `html' defined here...
doc/doxygen/Makefile.am:22:   `am/doxygen' included from here
automake: ... overrides Automake target `html' defined here
am/doxygen:70: consider using html-local instead of html
doc/doxygen/Makefile.am:22:   `am/doxygen' included from here
lib/Makefile.am:4: Libtool library used but `LIBTOOL' is undefined
lib/Makefile.am:4:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
lib/Makefile.am:4:   to `configure.ac' and run `aclocal' and `autoconf' again.
lib/Makefile.am:4:   If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
lib/Makefile.am:4:   its definition is in aclocal's search path.
--- Failed to build dune-common ---
Execution of dunecontrol terminated due to errors!




Martin Nolte wrote:
> > Error was in trunk, too. Fixed since 5430. Merge corresponding change to
> > release.
> >


-- 
------------------------------------------------------------------------------------------------------------------
Benedikt Oswald, Dr. sc. techn., dipl. El. Ing. ETH, www.psi.ch, Computational Accelerator Scientist,
Paul Scherrer  Institute (PSI), CH-5232 Villigen, Suisse, benedikt.oswald at psi.ch, +41(0)56 310 32 12
http://amas.web.psi.ch/people/boswald/index.html
------------------------------------------------------------------------------------------------------------------




More information about the Dune mailing list