[Dune] [#1048] ug.m4 does not find library in lib64, check version outdated

Dune flyspray at dune-project.org
Wed Mar 7 15:54:38 CET 2012


THIS IS AN AUTOMATED MESSAGE, DO NOT REPLY.

A new Flyspray task has been opened.  Details are below. 

User who did this - Christoph Grüninger (gruenich) 

Attached to Project - Dune
Summary - ug.m4 does not find library in lib64, check version outdated
Task Type - Bug Report
Category - UG
Status - New
Assigned To - 
Operating System - Linux 64bit
Severity - Medium
Priority - Normal
Reported Version - SVN (pre2.2)
Due in Version - 2.2
Due Date - Undecided
Details - I compiled UG-patch7, installed it with prefix in a directory and was not be found by dune-grid. The test ug.m4 checked prefix/lib but on my system it was installed in prefix/lib64. A symbolic link lib->lib64 did the trick.
This is hardcooded in ug.m4:
  PKG_CONFIG_PATH="$UGROOT:$UGROOT/lib/pkgconfig:$PKG_CONFIG_PATH"
Due to my lacking knowledge about PKG_CONFIG I didn't try to fix it by myself.

The version check in ug.m4 seems to be outdated, too:
--atleast-version=3.9.1-patch3

More information can be found at the following URL:
http://www.dune-project.org/flyspray/index.php?do=details&task_id=1048

You are receiving this message because you have requested it from the Flyspray bugtracking system.  If you did not expect this message or don't want to receive mails in future, you can change your notification settings at the URL shown above.



More information about the Dune mailing list