[Dune] trunk <-> 1.0

Markus Blatt Markus.Blatt at ipvs.uni-stuttgart.de
Fri Mar 23 13:43:17 CET 2007


On Fri, Mar 23, 2007 at 01:27:41PM +0100, Markus Blatt wrote:
> 
> IMHO there are quite some possibilities to overcome this problem:
> 
> 1. Make a branch that works with 1.0. IMHO this complicates things for
> the maintainer, i.e. I do not want to do this.
> 
> 2. Introduce forward compatibility into the release and skip the old
> version. Best for the user, additional work for 1.0 and against
> feature freeze!
> 
> 3. Introduce backward compatibility into the trunk and keep the
> additional modules to the old interface.
> 
> I would take route 3, as it does not delay 1.0 any
> further. (Eventually one would need to take route 1.0, though)
> 

Introducing defines of all module_versions we depend on (see issue
FS#274 in flyspray) would be another route that does not spoil the
dune module versions and even make incompatible interface changes
possible.

Markus



More information about the Dune mailing list